summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f8c7259..62f6ace 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,14 @@ case "${host}" in
esac
if test "x$BUILD_EVENTCOMM" = xyes; then
AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
+
+ if test "x$HAVE_XI22" = xyes; then
+ # Obtain compiler/linker options for mtdev
+ PKG_CHECK_MODULES(MTDEV, mtdev, HAVE_MTDEV="yes", HAVE_MTDEV="no")
+ fi
+ if test "x$HAVE_XI22" = xyes && test "x$HAVE_MTDEV" = xyes; then
+ AC_DEFINE(HAVE_MTDEV, 1, [MTDev available])
+ fi
fi
if test "x$BUILD_PSMCOMM" = xyes; then
AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])