summaryrefslogtreecommitdiff
path: root/gnu/llvm/unittests/IR/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/llvm/unittests/IR/CMakeLists.txt')
-rw-r--r--gnu/llvm/unittests/IR/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/llvm/unittests/IR/CMakeLists.txt b/gnu/llvm/unittests/IR/CMakeLists.txt
new file mode 100644
index 00000000000..5aad8edc913
--- /dev/null
+++ b/gnu/llvm/unittests/IR/CMakeLists.txt
@@ -0,0 +1,41 @@
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ AsmParser
+ Core
+ Support
+ )
+
+set(IRSources
+ AsmWriterTest.cpp
+ AttributesTest.cpp
+ ConstantRangeTest.cpp
+ ConstantsTest.cpp
+ DebugInfoTest.cpp
+ DominatorTreeTest.cpp
+ IRBuilderTest.cpp
+ InstructionsTest.cpp
+ LegacyPassManagerTest.cpp
+ MDBuilderTest.cpp
+ MetadataTest.cpp
+ PassManagerTest.cpp
+ PatternMatch.cpp
+ TypeBuilderTest.cpp
+ TypesTest.cpp
+ UseTest.cpp
+ UserTest.cpp
+ ValueHandleTest.cpp
+ ValueMapTest.cpp
+ ValueTest.cpp
+ VerifierTest.cpp
+ WaymarkTest.cpp
+ )
+
+# HACK: Declare a couple of source files as optionally compiled to satisfy the
+# missing-file-checker in LLVM's weird CMake build.
+set(LLVM_OPTIONAL_SOURCES
+ ValueMapTest.cpp
+ )
+
+add_llvm_unittest(IRTests
+ ${IRSources}
+ )